Java with Internet Explorer 11 incompatible?

After upgrading to Windows 8.1 you will find it impossible to use Java with internet explorer.

This is particularly bad for Oracle E-Business Suite that depends of the use of Java for its professional applications.

Problem Identification

You may get the warning:

Java(tm) Plug-In 2 SSV Helper’ from ‘Sun Microsystems, Inc.’ isn’t compatible with Internet Explorer’s enhanced security features and has been disabled:

Or you might just get stuck on:

In order to access this application, you must install the J2SE Plugin version 1.6.0_27…

Click tools: image 

Manage add-ons: image

And it shows:

image

Notice I’m using the 64-bit Java plug-in here.

And it’s incompatible…

Do not despair – there is a solution.

Solution

Enhanced Protected Mode 

Click tools: image

Internet Options: image

Select Advanced tab and scroll down to Security:

image

Uncheck “Enable Enhanced Protected Mode” as above.

Click OK and restart the browser.

In “Manage add-ons” you should now have:

image

If it is still disabled click on the Enable button: image

Compatibility View

Click tools: image 

Compatibility View Settings: image

Add current site:

image

Click: Add

Reconnect to your site.

You may get a pop-up warning – just click Always Allow:

image

And re-try.

In case it still doesn’t help, ensure:

  • Only to install JRE 6.0.27
  • In case you installed JRE 7.0.45 – when you open a R12.2 Java screen for the first time it will automatically install JRE 6.0.27. This is in spite R12.2 should have built-in support for JRE 7.0.45…
  • Add site to: Trusted Sites
  • Set security for Trusted Sites to Medium-Low

If it still doesn’t work it may be due to policy settings from your IT department…

This entry was written by Kent , posted on Friday November 08 2013at 10:11 am , filed under Office Tools, Technical Knowledge and tagged , , . Bookmark the permalink . Post a comment below or leave a trackback: Trackback URL.

Comments are closed.